Старый 21.03.2011, 01:42   #1
Rudaki
Banned
Доп. информация
По умолчанию Как проверить табличную часть на наличие определенного столбца?

Доброго времени суток. Вобщем делаю запрос по регистру, из него выципляю регистратор, потом из табличной части регистратора мне нужно выгрузить столбец "сумма", но может быть регистратор, в котором нет этого стобца, из этого вопрос, как это можно проверить? И еще, как проверить документ на наличие определенного реквизита?
 
Сказали 'Спасибо' за это сообщение.
Ответить с цитированием

Старый 20.12.2011, 00:28   #2
JayMF
Junior Member
Доп. информация
По умолчанию Re: Как проверить табличную часть на наличие определенного столбца?

// Позволяет определить есть ли среди реквизитов табличной части документа
// реквизит с переданным именем.
//
// Параметры:
// ?мяРеквизита - строковое имя искомого реквизита,
// МетаданныеДокумента - объект описания метаданных документа, среди реквизитов которого производится поиск.
// ?мяТабЧасти - строковое имя табличной части документа, среди реквизитов которого производится поиск
//
// Возвращаемое значение:
// ?стина - нашли реквизит с таким именем, Ложь - не нашли.
//
Функция ЕстьРеквизитТабЧастиДокум ента(?мяРеквизита, МетаданныеДокумента, ?мяТабЧасти) Экспорт

ТабЧасть = МетаданныеДокумента.Табли ныеЧасти.Найти(?мяТабЧаст );

Если ТабЧасть = Неопределено Тогда // Нет такой таб. части в документе
Возврат Ложь;

?наче
Возврат НЕ (ТабЧасть.Реквизиты.Найти(? мяРеквизита) = Неопределено);

КонецЕсли;

КонецФункции // ЕстьРеквизитТабЧастиДокум ента()



Функция ЕстьРеквизитДокумента(?мя еквизита, МетаданныеДокумента) Экспорт

Возврат НЕ (МетаданныеДокумента.Рекви зиты.Найти(?мяРеквизита) = Неопределено);

КонецФункции // ЕстьРеквизитДокумента()
 
Сказали 'Спасибо' за это сообщение.
Ответить с цитированием

Старый 29.11.2019, 12:41   #3
Avesbumer
на шаг впереди
Доп. информация
По умолчанию Как проверить табличную часть на наличие определенного столбца

Добрый день
Подскажите новичку. Ранее пользовался 1С 8. Занимаюсь продажами оборудования, интернет-магазин, нет программиста, в штате 2 человека. Иногда бывает нужно найти цену которую давал клиенту 1-2 года назад. Все счета перелопачивать очень не удобно. Помню в 1С 8 было удобно из номенклатуры товаров нажать на товар, небольшая манипуляция и выходит список счетов где присутствует этот товар. Как в 1С 7 это проделать ? Может отчет нужно вывести ?

Последний раз редактировалось almaz57; 29.11.2019 в 13:41..
 
Сказали 'Спасибо' за это сообщение.
Ответить с цитированием
Ответ


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход



Текущее время: 14:58. Часовой пояс GMT +4.


Powered by vBulletin® Version 5.0.2
Copyright ©2000 - 2019, vBulletin Solutions, Inc. Перевод: zCarot